interface Ethernet0/0
description WAN connection to Unifi BTU
no ip address
duplex auto
speed auto

interface Ethernet0/0.500
encapsulation dot1Q 500
pppoe enable group global
pppoe-client dial-pool-number 1

interface Ethernet0/1
description LAN Segment [192.168.1.0]
ip address 192.168.1.1 255.255.255.0
ip nat inside

interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
dialer idle-timeout 0
dialer persistent
ppp authentication chap pap callin
ppp chap hostname [email protected]
ppp chap password mypassword
ppp pap sent-username [email protected] password mypassword

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit
ip nat inside source list INTERNET_ACL interface Dialer1 overload

ip access-list extended INTERNET_ACL
permit ip 192.168.1.0 0.0.0.255 any

Incoming search terms:

  • configure streamyx cisco router
  • bridgecarter

    why do we need to create a sub interface 500 for ethernet 0 ?

  • bridgecarter

    and itzit possible for us to have multiple pppoe session on the router by having the same static route to different port like ip route 0.0.0.0 0.0.0.0 e1 and ip route 0.0.0.0 0.0.0.0 e2 ?

    • bridgecarter

      can load balancing occur by doing this ?

  • bridgecarter,
    1. Subinterface 500 is needed to “trunk” our e0/0 to BTU because we need to carry data vlan (500) and iptv vlan (600-config not shown here). BTU need to understand data packet tagged with vlan 500 for the internet packet.
    2.Yes you can have multiple PPoE sessions
    3. For redundancy, normally i will put a metric (ip route 0.0.0.0 0.0.0.0 e2 10). If you didn’t put a metric, i believed the outgoing traffic will be load balanced. You’ll then need to adjust your NAT configuration:

    UNIFI1 to f0/0, UNIFI1 to f0/1

    access-list 10 permit 192.168.1.0 0.0.0.255
     
    route-map UNIFI1 permit 10
    match ip address 10
    match interface FastEthernet0/0
     
    route-map UNIFI2 permit 10
    match ip address 10
    match interface FastEthernet0/1
     
    ip nat inside source route-map UNIFI1 interface FastEthernet0/0 overload
    ip nat inside source route-map UNIFI2 interface FastEthernet0/1 overload

    i have no time to test the NAT config, but in theory it should work. To eliminate complex network setup, you can buy cheap TP-LINK load balancer for better traffic control.