CyanogenMod is an aftermarket firmware for a number of cell phones based on the open-source Android operating system. It offers features not found in the official Android based firmwares of vendors of these cell phones.

Prerequisite:
1. Make sure you’re running ICS bootloaders. If you already running ICS then you’ll be fine. Follow this guide to upgrade to ICS.

Step 1- running a proper working ClockworkMod-Recovery
Since i9100g not officially supported by CWM, we need to use CWM that already built into the kernel (custom kernel). Download one of this kernel (from xda):
GB – 5.0.2.8
ICS – 5.5.0.4
ICS LP7 – 5.5.0.4

-Boot into Download-Mode using Volume Down + Home + Power
-Start ODIN and choose “GT-I9100G_XX_ClockworkMod-Recovery_X.X.X.X.tar” as PDA (no repartition)
-Connect your Phone and start flashing
-After reboot you can easily root your device using SuperOneClick

Step 2-Flashing CyanogenMod9
Get CM9 nightly build from http://download.cyanogenmod.com/?device=i9100g. Since Google Apps were taken out from CM9 ROM, you can get it from here.

– Copy GApps and CM9 ZIPs to your internal SDCard
– Boot into Recovery
– Flash CM9 zip from internal SDCard
– Flash GApps zip from internal SDCard
– DO A DATA WIPE / FACTORY RESET (otherwise your device will be stuck at boot)
– Reboot

Useful links:
Galaxy i9100G ROM/KERNEL List
[ROM][GT-I9100G][4.0.4] CyanogenMod 9 nightly builds! [>60FPS][ROCK-SOLID]
[KERNEL][GT-I9100G][GB+ICS/LP7] ClockworkMod Recovery 5
CM9 Download Page
Google Apps

Incoming search terms:

  • cynogenmod 9 tar
  • download cwm untuk samsung gti9100g ics
  • telecharger cmw GT-i9100G

This method is for users that were using custom ROM before ICS, by using custom ROM you’ll not be able to update to ICS over the air (using KIES).

1. Get official ICS firmware
Go to SamMobile Firmware Page and download latest ICS ROM. For Malaysia latest version is I9100GDXLP6 as the writing. Once downloaded, extract it and you’ll find I9100GDXLP6_I9100GOLBLP6_I9100GDXLP6_HOME.tar.md5 file.

2. Get ODIN
Download ODIN from here.

3. Download Mode
Start ODIN. Turn off your phone and go to Download Mode. Press and hold down Volume Down + Home + Power buttons at the same time. Odin download mode will be loaded.

4. Start flashing
In ODIN, select PDA and select I9100GDXLP6_I9100GOLBLP6_I9100GDXLP6_HOME.tar.md5 file. Do not tick anything other than this!

Remove USB cable from your phone when you see green PASS! at Odin3. That’s all and enjoys new firmware.

p/s: Do not wait too long between getting download mode and starting up ODIN.

Iperf was orginally developed by NLANR/DAST as a modern alternative for measuring maximum TCP and UDP bandwidth performance. Iperf allows the tuning of various parameters and UDP characteristics. Iperf reports bandwidth, delay jitter, datagram loss.

We’ll setting up 1 iperf client and 1 iperf server.
Continue reading

Incoming search terms:

  • Iperf ubuntu
  • ubuntu iperf
  • iperf for ubuntu
  • https://advanxer com/blog/2012/06/installing-iperf-on-ubuntu/
  • how to install iperf
  • ubuntu 14 4 iperf -w max
  • sudo apt-get install default-jdk iperf
  • apt-get iperf 2 0
  • iperf linux install
  • iperf instructions
  • cara install iperf di ubuntu
  • iperf apt-get
  • apt-get iperf

interface Ethernet0/0
description WAN connection to Unifi BTU
no ip address
duplex auto
speed auto

interface Ethernet0/0.500
encapsulation dot1Q 500
pppoe enable group global
pppoe-client dial-pool-number 1

interface Ethernet0/1
description LAN Segment [192.168.1.0]
ip address 192.168.1.1 255.255.255.0
ip nat inside

interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
dialer idle-timeout 0
dialer persistent
ppp authentication chap pap callin
ppp chap hostname [email protected]
ppp chap password mypassword
ppp pap sent-username [email protected] password mypassword

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit
ip nat inside source list INTERNET_ACL interface Dialer1 overload

ip access-list extended INTERNET_ACL
permit ip 192.168.1.0 0.0.0.255 any

Incoming search terms:

  • tm unifi cisco router

Differences between IOS and NXOS.

http://docwiki.cisco.com/wiki/Cisco_NX-OS/IOS_Software_Default_Configuration_Differences

IOS to NXOS migration tool
http://tools.cisco.com/nxmt/

Minimum Recommended Code Levels.
http://www.cisco.com/en/US/docs/switches/datacenter/sw/nx-os/recommended_releases/recommended_nx-os_releases.html

Data Center switching support forums on Cisco.com.
https://supportforums.cisco.com/community/netpro/data-center/server-network

#########################################################################
Configure IP
/etc/rc.conf
ifconfig_em0=”inet 192.168.0.254 netmask 255.255.255.0″
defaultrouter=”192.168.0.1″
#########################################################################
Using Portsnap

portsnap fetch extract
portsnap update
*etc/portsnap.conf

pkg_add -r -v {package-name}
pkg_info
pkg_info {name}
# whereis bash
# cd /usr/ports/shells/bash
# make install clean

#########################################################################

Overview

A virtual PortChannel (vPC) allows links that are physically connected to two different Cisco Nexus 5000 Series devices to appear as a single PortChannel to a third device. The third device can be a Cisco Nexus 2000 Series Fabric Extender or a switch, server, or any other networking device. A vPC can provide Layer 2 multipathing, which allows you to create redundancy by increasing bandwidth, enabling multiple parallel paths between nodes and load-balancing traffic where alternative paths exist.

Continue reading

DDNS stands for Dynamic DNS. Simply put, using this service gives a name to your ip. So if you’re hosting something on your line, people wouldn’t have to bother typing your IP. They can just type in your domain name! It also helps when your ip changes. Users won’t need to discover what your new ip is, they can simply type your domain name. Continue reading

UPnP is used to replace manual port forwarding. Some gaming box (XBOX, PS3) will need UPnP feature to connect to their respective server. Enabling it in OpenWRT Backfire is relatively easy. Continue reading

Incoming search terms:

  • openwrt upnp
  • openwrt
  • upnp openwrt
  • NULL
  • ebox openwrt
  • luci upnp
  • luci-app-upnp
  • openwrt upnp gui
  • openwrt upnp luci